Sidebar Connect Submenu not opening

Discussion in 'Connect - CSV Widgets' started by nsiegel, Nov 11, 2016.

  1. nsiegel

    nsiegel New Member

    1
    0
    I love this widget! My submenus are opening fine as flyouts, but when viewed on mobile device (such as i-phone) they are not opening/ rolling out below. Can you help trouble shoot this asap?

    Thanks!
     
  2. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,074
    231
    nsiegel, when you try opening the drop down on your phone, are you clicking on the drop down arrow or one of the titles?
    Take a look at our Demo on the product page, if you click on the arrow next to 'Products' (not the word Products), does the drop down function?
    Thanks
    Dj
     
  3. Susanne Axelsen

    Susanne Axelsen Member

    5
    0
    We have the same problem on phones. Not all the time but very often. The menu freezes and wont fold out even though you click on the drop down arrrow. We are testing with the 1.5 version of sidebar connect. And with the new possibility to not have links on the "parent" menu item. If you click on a menuitem thats does not have any submenu items there are no problems.
     
  4. John DIGITAL

    John DIGITAL Member

    17
    0
    I have the same problem with v1.5 - workaround is to put a "#" in the URL field in the spread sheet - not ideal tho
     
  5. Pete Smithies

    Pete Smithies Member

    5
    0
    I have a problem with widget on a phone, sometimes "locking up" in that drop downs will either not drop down, or if already down..... will not roll up again.
    www.tarata.co.nz
    Can anyone shed any light on this?
    Pete
     
  6. Mick

    Mick Member

    10
    0
    Hi DJ, I'm using the menu as well and when I tap on the dropdown arrows for mobile submenus, they do not work if I've scrolled the page. If I don't touch the page, it works. But if I scroll, they stop working. Any way to fix this?
     
  7. Jeremei

    Jeremei Well-Known Member

    743
    95
    I have also noticed that sometimes (not all the time) mobile submenu arrows are not opening submenu items. Often after refreshing the page they start to work again in a proper way. There is something a little wrong what should be checked by the technical team of Muse-Themes. Thank you! :rolleyes:
     
  8. ProperBoPeep

    ProperBoPeep Member

    7
    1
    I appear to have this problem too and I use the SideBar Connect in all breakpoints of my site. If I view the site on any iOS device, then the submenus only open if the page HASN'T been scrolled. Once the page has been scrolled, only a browser refresh or going to the top of the page seems to facilitate the sub-menus opening again.

    *EDIT - I have now noticed that the glitch appears to be on iOS when the URL box on the top of the screen reduces in size when you scroll down. But if you scroll UP, just enough to make the URL box appear, then the submenus open up again *

    The widget works fine when I view on a desktop (Firefox, Windows 10) and I reduce the browser size to mimic mobile, the problem doesn't occur.

    I have had some problems with Table Connect not working with iPhones as well.

    If anyone has worked out a solution, please let me know.

    Thank you.
     
    Last edited: May 22, 2017
  9. Roger

    Roger Well-Known Member

    69
    4
    ProperBoPeep

    I have exactly the same issue as you.... on IOS devices

    Open up a page with Sidebar Connect and submenus work.... as soon as I scroll down even a centimetre... I can still open sidebar connect menu, but all the sub menus will not open.

    I have to scroll back up right to the top or refresh the page.

    Obviously there is an issue here if two people are seeing this..

    Ive just noticed Im using version 1.4 (bugger)..... a seriously good widget and hope that someone can come back to us ... maybe I have a wrong setting?... just want to make sure that this will not happen in version 1.5 as its a 250 page website and only want to put the work in if I know 1.5 resolves this

    Any ideas?
     
  10. John DIGITAL

    John DIGITAL Member

    17
    0
    I am using version 1.5 and it the issue remains.
     
  11. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,074
    231
    All, I looked into this and I see that this has been reported as a bug and passed to the developers.
    I am attempting to see if there is any idea of a time frame for a fix (or if the developer has any info).
    If I can find anything out I will pass it along as soon as I hear.
    Thanks you for letting us know.
    Dj
     
  12. Roger

    Roger Well-Known Member

    69
    4
    DJ... that would be very helpful

    Thank you
     
  13. Roger

    Roger Well-Known Member

    69
    4
    I have to ask this question as its now delayed my 250 page website which relies on this mobile navigation....

    How is it that this passed testing when it would appear not to work on IOS devices?.. iPads and iPhones must surely represent a huge level if usage for what I assume is deemed to be a widget designed for this type of device.

    I would have thought it would have been fully tested on IOS and Android for a relatively simple function of ... 'does it work if I scroll down a bit...'

    If Im right, its not easy to see the widget functioning unless you publish it?... This has unfortunately affected me badly as I have a big website published which now doesn't work effective on mobile devices.
     
  14. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,074
    231
    Roger, I can't speak to everything the development team goes through in thier process, but I encourage you to ask this directly to them in a support ticket (resources>contact us).
    Thank you
    Dj
     
  15. Roger

    Roger Well-Known Member

    69
    4
    I DJ...

    Did you manage to find out a timescale for the bug fix?... This is a pretty major issue for me and I cant release my website without it....

    Any info is greatly appreciated

    Thanks
     
  16. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,074
    231
    Roger, I took this further up the line and talked with the developer.
    They are going to look at it, but I got the sense it may be awhile.
    Right now all I can offer is to stay on them, and keep you informed.
    Additionally, I would recommend you let them know how important this is and push them also through the support team, and see if they can push it even further.
    Sorry I don't have better news.
    Dj
     
  17. Roger

    Roger Well-Known Member

    69
    4
    Thanks DJ.... not your fault of course but seems disappointing to have something out and released which doesn't work on iPhones and iPads which would I guess alienates a massive portion of internet users. Also I will say its disappointing that if this is known, it should be prioritised, a menu system is extremely important to websites.

    This is I guess my interpretation of the bug and it would be useful to know from others if this is indeed the case?... So to all out there who also thinks this is a great widget, are you all also experiencing this bug with IOS devices?.... If so, and if others could make this known to support, it may bolster the need for a speedy fix.

    is anyone else out there experiencing this..? Mat be worth checking.

    Regards
     
  18. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,074
    231
    Roger, I completely understand, and let me clarify my previous response.
    Right now, there is still (in the grand scheme of things) only a few that have been reporting this. So, when I said I don't think a fix will be soon, I did not mean to imply that it wasn't important or that the developers wouldn't place any urgency around it.
    What I should have said, is that the widget needs to be evaluated, and a fix (if one is found to be required, which I trust yours and others information will bare out) needs to worked out, re test ect.
    So, the time frame wouldn't look to be a quick one, since this is the beginning stage of the process.
    I didn't want to lay all that out and sound like a robot, but I do want to be clear that we are not going to push it to the side.
    Hope that makes sense.
    Thanks (and thank you for placing the ticket, those do help, especially if the team needs supporting files to help with it).
    Dj
     
  19. Roger

    Roger Well-Known Member

    69
    4
    Understodd DJ.... Its why i asked the general public here to speak up if they are also seeing the same issue

    Thanks
     
  20. Brett Aubry

    Brett Aubry Member

    5
    0
    Hello all,
    First time poster, I might have missed it, but what do I put in the url if I just want it to open another page and not an outside link? For example, if on the home page I want to click the about and go to that page in the website?

    thanks
     

Share This Page