SHOW Video Suite-poster pic and other devices

Discussion in 'SHOW Responsive Video Suite' started by Berat, Oct 7, 2017.

  1. Berat

    Berat Member

    13
    0
    Hello I still did not get a response how SHOW Video suite widget when applied a poster pic the all browser will show it first then the video. Can someone help me fix this besides just not adding the poster pic.

    I checked my all devices from iPad pro-other generation, my iPhone and Android.
    The background video of our home web page does not work at all
    both using local and external (youtube) with youtube its just a picture with fake play icon that does not show the video at all. Can we fix this?
    Does the SHOW Video suite only capable in browsers?
     
  2. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    2,862
    215
    Berat, please let me know if I have not understood your questions correctly.
    I think your first question is stating that you are getting a poster image instead of your Video?
    Regarding the poster image displaying first, this could be happening if you're previewing the site. Often times with video widgets, previewing a site won't show the full functionality, and in some browsers, won't function at all. The better test is to publish your site, and see if it works.
    Your other issue sounds like you are having a problem using the Background Video (and I am going to assume you mean having it play) when on anything that could be construed as a Mobile device?
    This would be normal on Mobile. Until recently, most if not all mobile browsers have been designed to not allow auto start videos on Mobile devices. A Background video is an auto start video. This is not a widget issue, it's the Browsers designers and Carriers working to limit unwanted data downloads on Mobile. This is why the widget, and others like it ask for a poster image to show in the window rather than a blank screen when auto start is blocked.
    I am still looking at new changes to this and this browser /carrier issue may be changing. For now, this is an article that gives a brief explanation about this. https://www.dacast.com/blog/why-video-autoplay-does-not-work-on-mobiles/
    I recommend trying our new Hero Connect widget, which allows images, and/or video, in a Hero background, that you can size from full screen to a specific hero size.
    Dj
     

Share This Page