Solved Search Essentials Widget

Discussion in 'All Other Widgets' started by VeeVee3, Jun 1, 2017.

  1. VeeVee3

    VeeVee3 Well-Known Member

    46
    0
    Hello,

    I watched the video on the search essentials widget. I set everything up like how it's supposed to be. When I preview the widget in the browser and put in a word for search. It doesn't take me to the search page that I set up. It takes me to a white blank page. Please help. Thanks
     
  2. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,348
    250
    VeeVee, if you could post a couple of screen shots on how your settings are, and maybe of how it loos in both design and plan mode.
    Thanks
    Dj
     
  3. VeeVee3

    VeeVee3 Well-Known Member

    46
    0
    Screen Shot 2017-06-01 at 6.50.47 PM.png Screen Shot 2017-06-01 at 6.51.35 PM.png Screen Shot 2017-06-01 at 6.51.11 PM.png Screen Shot 2017-06-01 at 6.51.56 PM.png
     

    Attached Files:

  4. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,348
    250
    VeeVee, OK, let's try a couple of things.
    First, you should try to place the search box portion on the Master page.
    Next, be sure to use the correct convention when typing in the page names. I see your "help-videos" doesn't have Html after it as well as it has an additional apostrophe. Your "sample-sites" needs the Html also.
    Change those items and let me know how it looks.
    Thanks
    Dj
     
  5. VeeVee3

    VeeVee3 Well-Known Member

    46
    0
    Hello,
    I put my search box on the master page, and then I changed the syntax in the search box to make sure all the pages have the quotations and Html tags, and I'm still running into the same problem.
     
  6. Jeremei

    Jeremei Well-Known Member

    745
    97
    Very strange if you made everything what Dj. said?
    I created exactly the same pages as you have in your Muse file and everything worked in a proper way in my Muse file!
    You can do as following:
    1) Empty caches from the browser and close the browser.
    2) Open the browser after 2 minutes.
    3) Check that "Search Result" widget layer is not under the flower image on "Search" page in layers´ panel? If it is so move it to the top in layers´ panel. :oops:
     
  7. VeeVee3

    VeeVee3 Well-Known Member

    46
    0
    Ok, that seemed to have worked. Is there a way to only have the search bar on some pages and not on others?
     
  8. Jeremei

    Jeremei Well-Known Member

    745
    97
    Of course! Just write to "Search Results" widget - "Included Pages " field which pages you want to be included.
     
  9. VeeVee3

    VeeVee3 Well-Known Member

    46
    0
    I did that and that didn't work. What I meant was, I only want the search field to appear on the home page, and not the other pages. I did what you said and the search field was still on the other pages. It seems for the search field to work I have to include it on the master page, but when I do that it appears on all pages. I tried just putting it on the home page and I was having issues.
     
  10. Jeremei

    Jeremei Well-Known Member

    745
    97
    You can use two Master Pages, A and B. A-Master Page with Search Field (Home Page) and B-Master Page (other pages) without Search Field.
     
  11. VeeVee3

    VeeVee3 Well-Known Member

    46
    0
    Thanks Got it ;-)
     

Share This Page