Reviews Connect Carousel View: Always showing an extra "empty" review?

Discussion in 'Connect - CSV Widgets' started by Keith Crosley, Jul 21, 2017.

Thread Status:
Not open for further replies.
  1. Keith Crosley

    Keith Crosley Member

    10
    0
    Reported this to support as well, but: I'm using Reviews Connect controlled by LOCAL csv files. My content is displayed in Carousel mode/view. What I find is that, no matter how many reviews I have in my content file, Reviews Connect is always showing n+1 reviews with the last review being "empty" (i.e., there's not content in it, just the quote wrappers and stuff).

    And no, I don't have a "blank" line at the end of my csv content file. I'm not sure if this is something weird with the way Excel exports csv files or what.

    Has anyone else seen this behavior? Know of a fix?
     
  2. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,459
    255
    Keith, could you show me a screen shot of your page in Browser, and in design mode?
    thanks
    Dj
     
  3. Keith Crosley

    Keith Crosley Member

    10
    0
    Hi Dj,

    Sure. Views of RC widget in design more, same page in browser (showing "phantom" review), and Excel showing the CSV content source material attached!

    Best Regards,
    Keith
    rc design view.JPG rc edge view.JPG rc csv view.JPG
     
  4. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,459
    255
    Keith, I looked for your ticket in our support area, and I didn't see it. Did you get a response (automated or live?).
    I am able to replicate it so I am also asking our team what might be wrong, and will comment here when I get an answer.
    Thanks
    Dj
     
    Keith Crosley likes this.
  5. Keith Crosley

    Keith Crosley Member

    10
    0
    Hi Dj,

    Yeah it looks like perhaps my bug submission didn't "stick" -- I did not get an email confirmation. Glad I posted here, then. Seems you are able to reproduce! I am getting notifications for this thread. Thanks for looking into this. I really want to deploy this widget in my live site, but that "extra" empty does bug me! :p
     
  6. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,459
    255
    Keith, I have given the team my test files, so hopefully they can check this out.
    I'm going to recommend you still place a support ticket (resources>contact us) to put some pressure from your side.
    Thanks
    Dj
     
  7. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,459
    255
    Keith, It may not be what you're looking for, but I believe everything works fine using the Google Sheets method.
    I was able to add and delete as designed with no additional quotes.
    This may be the way to go until I find out more about the CSV files.
    It's not a lot different except you don't need to give the file to anyone if your wanting to keep it out of your clients hands.
    Just a thought
    Dj
     
  8. Keith Crosley

    Keith Crosley Member

    10
    0
    Thanks, Dj. I filed a support ticket (seems to have worked this time). Yeah, guess I could go the Google sheets route. Seemed easier for me to use local csv though. (site is my own, no client)
     
  9. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,459
    255
    Keith, by now I'm sure the support team has told you what the developer found.
    I wanted to make sure but also let anyone following this thread know what took place.
    The issue Keith was having was when using the CSV Content file (the Google sheets worked as designed), the widget was being told to add an extra line after an entry.
    We will be updating the Widget soon, so stay tuned.
    Keith, thank you for your help. As always, you folks are what makes us better.
    Dj
     
    Keith Crosley likes this.
  10. Keith Crosley

    Keith Crosley Member

    10
    0
    Thanks, Dj. So, I did discover a workaround. The issue seems to be this: For whatever reason, the Excel file (I'm using Excel 2016 on Win10) exported CSV format from Excel "appears" to the widget to have multiple blank rows after the last of my reviews.

    This doesn't make sense to me (there are no values in the rows), but there it is. I was able to "remove" the offending rows by (1) uploading the CSV to Google Drive, opening that in Google Sheets and selecting any additional rows below the reviews content. By default, Sheets seems to show 1000 rows or something. So, I selected those rows and deleted them. With Google Sheets showing only my 20-is review rows, I then downloaded the .csv file to my local machine and used *that new one* as the local source in Reviews Connect.

    When previewed or published, the "phantom" review is now gone. I have no idea what might happen the next time I edit the csv locally and whether that will make "empty" rows reappear, but at least this seems to be a (somewhat annoying, but at least free) solution to preparing a "clean" csv file for use with Reviews Connect.

    I *do* think there's something of a bug here, but I'm not really sure of the source of it (i.e., is this a weirdness specific to Excel, or is this Reviews Connect not properly interpreting the end-of-file for the .csv).

    Best Regards,
    Keith
     
Thread Status:
Not open for further replies.

Share This Page