Rapid Reveal Position

Discussion in 'All Other Widgets' started by Allen Brown, Sep 20, 2017.

Tags:
  1. Allen Brown

    Allen Brown New Member

    3
    0
    I'm using Rapid Reveal with a pinned header. "Enable Scrolling To Preview" kicks the reveal underneath the header... If I disable the "Enable Scrolling To Preview" the reveal opens below the viewable area so that the user wouldn't see that it opened.

    Is there a way to edit the widget html to set the location of the reveal?
     
  2. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,083
    233
    Allen, could you show a screen shot or two of your layout in Muse?
    If possible, show the whole screen including the Muse interface.
    Also, your Muse version if you don't mind.
    Thanks
    Dj
     
  3. Allen Brown

    Allen Brown New Member

    3
    0
    I’m using Muse 2017.2 Beta because the 2017.1 update totally screwed up my entire site. Before the 2017.1 update the rapid reveal was behaving the same, so the beta isn’t the issue. In the first screen shot below you can see only three of six total Rapid Reveal photos. If the user selects a Rapid Reveal pane without “Enable Scrolling To Preview” checked, the revealed content opens below the viewable area and the user wouldn’t know it opened.

    upload_2017-9-21_2-39-54.png





    Since I’m working in the Beta version of Muse I’m required to transfer everything over from my original site design that was screwed up due to the 2017.1 update, so you’ll have to ignore the small font size in the content list as I haven’t added the CSS to increase its size yet. This next shot below I’m previewing in the browser with “Enable Scrolling To Preview” checked, and the “Custom Five Star Plans” pane selected revealing its content. As you can see, my pinned header is blocking the very top of the revealed content when it opens in its default position.


    upload_2017-9-21_2-40-44.png



    I want to be able to set the position of the opened revealed content as shown in the below screenshot. As you can see, this position would display the entire revealed content including the “X” that closes the individual revealed window.


    upload_2017-9-21_2-41-26.png
     
  4. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,083
    233
    Allen, thank you for the information.
    I am reaching out to the development team to see what they say about a solution.
    I'll keep you posted.
    Thanks
    Dj
     
  5. Allen Brown

    Allen Brown New Member

    3
    0
  6. uncagedcreative

    uncagedcreative Member

    19
    3
    Was there any development on this? I'm placing Rapid Reveal for the first time on a site and witnessing the same behavior as the OP. Thanks!
     
  7. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,083
    233
    uncaged, I apologize for leaving this thread unfinished. The Original Poster actually also placed a support ticket, and he was answered there.
    It appears that there is no option for the positioning other than by manually placing the slides location relative to the header.
    The closest I can get to aligning as the OP wanted using the widget settings, is to adjust the Grid Padding in the widget panel to something like 20px. The downside with that (in some designs) , is it also placed spacing between the image thumbnails.
    Thanks
    Dj
     
  8. uncagedcreative

    uncagedcreative Member

    19
    3
    Thanks, it looks like I'm either just going to live with it scrolling to where it does (and thanks to padding, it's close to going under the navigation at the top (pinned nav) but not enough that it interferes with the text) or not use the widget at all and just come up with another solution.

    The other issue I'm having is not in particular to this widget but I am trying to get this widget to do it. I'm using brandon-grotesque black for the headline but it only shows in the code (CSS) as brandon-grotesque with a font weight of 900. Is it possible to get the widget to do type weights?

    Thanks!
     
  9. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,083
    233
    uncaged, that's a good question about the fonts.
    I did a quick test, and found this to work for me.
    One thing that gets missed a lot with text in widgets (in Muse), is that Muse needs to see the font on the page in order to match up with the widgets request. So often, placing the text somewhere on the page gets over looked. If the font is NOT being used in the page content, then this text placement can be as simple a letter or dash somewhere on the page (you can even make it the same color as the background).
    So, back to the test.
    I placed some text on my page using brandon-grotesque. I used the text brandon-grotesque black. In the widget I just placed the font type as brandon-grotesque. The result came out as desired.
    To be sure I then made my page type brandon-grotesque light, and without changing anything in the widget it came out as brandon-grotesque light.
    Give that a shot.
    Dj
     

Share This Page