Solved NAV SYSTEM PRO WIDGET

Discussion in 'All Other Widgets' started by Huddo, Aug 2, 2017.

  1. Huddo

    Huddo Active Member

    26
    0
    Hi, is anyone else having an issue with this widget? When testing the site the navigation doesn't recognise the pages and can not navigate to the page requested. I Get an error! I am using https://www.domainname.com/about.html values.. is this correct?

    I've attached a screen shot of the error I get when clicking onto the 'menu name'.
    TIA JILL
     

    Attached Files:

  2. Jeremei

    Jeremei Well-Known Member

    745
    97
    Huddo!
    1) Your graphic style name must be correct; same as in Nav System Pro widget - Open Button Graphic Style

    2) Nav System Pro - Loader widget
    Menu Item 1;
    - you must check "Enable Item 1"
    - Menu Item 1 Type, select "Link"
    - Menu Item 1 URL, write there index.html (= Home Page), in other Menu Items 2 > you must write page name plus html e.g. about.html, services.html, etc.
    - Menu Item 1 Text field, write there Home (About, Services etc. in other menu items)

    I tested Nav System Pro widget version 1.2 and it was working correctly.
     
    Huddo likes this.
  3. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,401
    251
    Jill, I don't want to assume, so I need to ask, your site is an HTTPS site not HTTP site, correct?
    Dj
     
  4. Huddo

    Huddo Active Member

    26
    0
    Hi DJHerold,

    No it is not!!! Although I have tried both - https:// and http://.. I have not tried it again since I have updated the widget.
    Thank you.... will try it again now. - Jill
     
  5. Huddo

    Huddo Active Member

    26
    0
    Hi Jeremi - thank you for your time in answering my question. I will try it out and get back to you - many thanks,Jill
     
  6. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,401
    251
    Jill, I'm not sure why you would be trying to use Https ("I am using https://www.domainname.com/about.html") if your domain is Http?
    You should be able to just place something like yourpagename.html in the link area to go to that page. So, in your example url above, the link name would be houseinterior.html. Try to use lowercase, no spaces, no special characters.
    Could you possibly post a couple of screen shots of your setting in the widget?
    Thanks
    Dj
     
  7. Huddo

    Huddo Active Member

    26
    0
    DjHerold. Thank you... It is now working. I had put the full http and domain name in all values. DOH!!! So now I have just put (apart from the home page which is full domain and index.html).. About.html, Contact.html.
    Thank you very much for your time.regards Jill
     

Share This Page