Solved MENU NOT WORKING ON MOBILE format

Discussion in 'Stacks' started by Aldo Carbonari, Apr 12, 2016.

  1. Aldo Carbonari

    Aldo Carbonari Member

    16
    0
    The Hamburger menu does not activate to a drop down menu when previewing on a mobile (portrait and landscape) and not on an iPad (portrait) - you just get a big white cross.

    Thanks Screen-Shot-2016-04-12-at-18.57.24.jpg
     
  2. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,456
    255
    Aldo, I can't seem to replicate that issue, could you post a screen shot of your fly out panel.
    Thanks
    Dj
     
  3. Aldo Carbonari

    Aldo Carbonari Member

    16
    0
    Hi Dj,
    Here you go - hopefully this helps.
    Thanks Screen-Shot-2016-04-12-at-20.08.07.jpg
     
  4. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,456
    255
    Aldo, to be honest, I don't know why this is happening. I have the same set up (just the default, just drag and drop) and everything is working fine.
    I do n't know if you have changed anything else, but I see you've changed the logo. So, let's try this, create a new page blank page and place the widget on it. Don't change anything, just place it and then "Pre view in Browser". Does it work as it should?
    If it does, then I'd go back to your original and check the 'States' of the open and close button. You may have altered those.
    Let me know
    Dj
     
  5. Aldo Carbonari

    Aldo Carbonari Member

    16
    0
    I have copied my file and stripped the header and Logo out, then drag and dropped the Header in to my Muse file. When I Preview in Browser it works fine, but when I publish a test to Business Catalyst (http://smrtjtest1.businesscatalyst.com/index.html) and view on my iPhone the new Header does not work!

    Any Help would be great.
     
  6. Jeremei

    Jeremei Well-Known Member

    745
    97
    Aldo!
    Everything is working ok to 769 px (width) but from 768 px downwards menu items dissappear. It seems to me that the menu items would be under the photo or under the black menu bar? Did you check this possibility?
     
  7. Aldo Carbonari

    Aldo Carbonari Member

    16
    0
    Hi Jeremei,
    The Header panel is on the Master page and the photo on a separate page (Home) so I cannot see how this can be covering it up. The issue seems to be with the activation Hamburger from 768px down ... very strange
     
  8. Jeremei

    Jeremei Well-Known Member

    745
    97
    Aldo!
    Have you tried to put the Header to Home page? Put it directly to Home page and check the result! You don´t need to put the Header always to Master page.
     
  9. Jeremei

    Jeremei Well-Known Member

    745
    97
    Aldo!
    I tested the Header directly on the Home page and it is working correctly. Look at pictures

    Home_Co__Break_Points_1.png Home_Co__Break_Points_2.png Home_Co__Break_Points.png
     
    Aldo Carbonari likes this.
  10. Aldo Carbonari

    Aldo Carbonari Member

    16
    0
    Hi Jeremei,
    It works well when pasted on to the Home page rather than in the Master Page - thanks for your help. Do you have any ideas as to the query regarding the
    MOVING TEXT PANEL?
     

Share This Page