Gallery Connect - User Feedback

Discussion in 'Connect - CSV Widgets' started by Steve Harris, Oct 19, 2016.

  1. Steve Harris

    Steve Harris Museologist Staff Member Moderator

    215
    80
    Hi Guys!

    We're so excited to release the new Gallery Connect widget. This was a big project for our team, and we would absolutely love to hear your feedback and requests to make this the best widget it can be. Please post any feedback you have below as we're planning on a doing a round of updates soon.

    http://www.muse-themes.com/products/gallery-connect

    Thanks!
     
    furtun likes this.
  2. Nige

    Nige New Member

    2
    0
    Hi Steve and team! Great integration of gallery connect, having a quick look through, I have a request, would it be possible to include Google fonts to titles and descriptions? So to style the same as the site..

    Great work again guys..

    Regards Nige
     
  3. Steve Harris

    Steve Harris Museologist Staff Member Moderator

    215
    80
    Hey Nige,

    Thanks so much! That's awesome to hear.

    You can definitely use any font you'd like in Gallery connect! The font options are in the widget panel. In order to use a Google Font you would just need to enter the font name (and embed the font in the head of your Muse site).

    For example:
    https://fonts.google.com/specimen/Roboto?selection.family=Roboto

    Embed: <link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
    Then use the font name: 'Roboto', sans-serif;

    Cheers
    SH
     
  4. Nige

    Nige New Member

    2
    0
    Thanks Steve, I'm on it!

    Regards Nige
     
  5. Steve Harris

    Steve Harris Museologist Staff Member Moderator

    215
    80
    Side note... we're testing this. BUT if we find an issue, we'll push out an update right away. Since updating this widget is so easy and doesn't undo all your work. Hooray for all the important stuff living in the spreadsheet.

    UPDATE - our test worked just fine!
     
    Last edited: Oct 19, 2016
  6. Alex299

    Alex299 New Member

    4
    1
    Thank you guys SO MUCH for this widget! Ive been waiting for something like this for so long and it's perfect! It makes my life so much easier.

    I cant seem to get links to work though. Nothing happens when I click the thumbnail. When I hover on the thumbnail the lower left corner of chrome says "javascript:void(0)" where the link should be.

    Heres my setting .csv
    https://docs.google.com/spreadsheet...OODQLngiWgFBjQXDYm-PPj0PA/edit#gid=1860676824
     
    Jesse likes this.
  7. L3SAN

    L3SAN New Member

    2
    0
    Hi,

    This widget looks great and i'm really considering becoming a paid member to get all the awesome widgets. There is just 1 suggestion i would like for you to add.

    - Randomize Images on page load.
    - Filter Option


    I really hope that would be possible, i run a wallpaper website and it would be great for the wallpapers to load. at random. The filter option would also be a great feature! I'm currently working on my portfolio website. I'm using another lightbox widget. It does not have a filter option or random image option. If you can implement that i would eliminate the amount of pages i have to have on my website. Since it would have a filter the user can just select what they want to view.

    thank you,

    Lesan.
     
  8. Jesse

    Jesse Well-Known Member

    56
    4
    Same...I need the links to work...just made a whole site except the links don't work.
     
  9. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,074
    231
    Jesse, could you describe a bit more what you are doing when you say the links don't work?
    Thanks
    Dj
     
    Gerkaly likes this.
  10. Jesse

    Jesse Well-Known Member

    56
    4
    Here is the link to the page having the issue: http://richardmandelkorn.com/portfolio.html

    I set up hyperlinks instead instead of using the lightbox and they don't work. When I hover they all say javascript:void (0).

    --

    Also...when using this site on Safari on iphone 6S and 7+....when we rotate the phone from portrait to landscape....its getting stuck. If you move it or wait a while it sometimes works.
     

    Attached Files:

  11. James007

    James007 Active Member

    25
    1
    This looks complicated. Is it embarassing if I admit I've never been good with spreadsheets?

    I use Muse for the design aspect, I don't want to mess around with CSV styling spreadsheets to achieve my desired look. I'm sure you can understand.
     
  12. Jim-FL

    Jim-FL New Member

    1
    0
    I am unable to extract the zipped files in "- MT - Toolbox - CSV - Gallery Connect (beta v1).zip" because the csv filenames are too long.
    I am using Windows 10 Pro, also enabled long file path names in the Local Policy and Registry, restarted, and still unable to extract the files. See the attached png for a detailed description of the error.
    The root folder that contains the zip file for the attempted extraction is:
    C:\Users\MMM\Desktop\Design Tools\Muse Themes\Widgets\MuseThemes - Widget Bundle 1.0.54\Current Widgets (Responsive Muse) 1.0.54
    Can you possibly reduce the csv file names, while maintaining their descriptive attributes, to accommodate the path size restriction and redeploy the zip?
    If not, is there a dependency on the csv filename within the "- MT - Toolbox - CSV - Gallery Connect (beta v1).mulib" widget such that the full filename needs to be preserved as it currently is in the zip file?
    -----
    Updated 10/20/2016 - Just watched the demo video.
    Wow, I like it!
    Also, I see the csv filenames are not a dependency as they are configurable within the widgets setup properties.
    As to the long filenames...this is a problem that may not occur since the error is only triggered if the total path and fllename exceeds Windows 10 threshold. However if you have a structured hierarchy for your files and you are encountering this problem there is a workaround. Copy each csv file from the zip into a path where the total path length, including the filename, is acceptable. Then rename and reduce the filename size of the csv and move the csv file to your intended location.
     

    Attached Files:

    Last edited: Oct 20, 2016
  13. Rumbo

    Rumbo Member

    7
    0
    This is an incredible gallery widget, thank you for creating it!
    I have instantly implemented it into my site which I'm currently creating. I'm quite new to Muse and I'm also not an expert in CSV. And there is my question. I need to have special characters in my image titles and description such as ® or ™. I have put these into the CSV file title and description and they are being shown just fine. However once I look at the gallery in the browser it only comes up with small "�". How can I achieve to display the special character correctly? Is there a trick?

    I have tried different fonts without any better result.
     
  14. furtun

    furtun New Member

    1
    0
    Very handy widget. Thanks to the team. Everything works fine except the custom thumbnail. I tried both uniform and mosaic grid and couldn't manage the get custom thumbs work. It prefers to generate the thumbs instead of getting the links from csv file.
     
    Last edited: Oct 20, 2016
  15. L3SAN

    L3SAN New Member

    2
    0
    James, the spreadsheets are used to be able to easily customize the widget. It's a new way of doing something.. You can completely ignore it it's not a must use thing.
     
  16. razah

    razah Active Member

    35
    2
    Hello!

    Unfortunatly I cant get the font familys to work. I added Roboto Condensed as a typekit font and wanted to use it in the gallery as well (
    <link href="https://fonts.googleapis.com/css?family=Roboto+Condensed:300,300i,400,700" rel="stylesheet">). I did the same steps Google recommends: Adding the HTML-Code into the head of my master page and then using "Roboto Condensed, sans-serif;" in the settings of the widget. But they do not change. What am I doing wrong? When I add ' to the front and back of the fontfamily name, I am getting a error 503.

    thanks for this great gallery widget!
     
  17. wesm12

    wesm12 Member

    13
    1
    Hi Muse team.. Love this new widget. I am having trouble using the "url" in the .csv file...they don't seem to be working in my test site. Love the video Mr. Harris. Easy to understand and explained well.

    I added a new image to my copy of the .csv, changed the image source for the thumbnail and larger image, entered the url where I want people to go to, but there is nowhere for them to click on.It does perplex me...

    The image does not link or the description or the alt text..Please help...did I miss something. I can click on the url in the .csv file and it works, but does not work in preview page mode
    Thank you
     
  18. Steve Harris

    Steve Harris Museologist Staff Member Moderator

    215
    80
    Hey all! Thanks for the great feedback / questions. Most of the team is still coming to life (lots of night owls in this company) so I suggested to the guys that we float around this thread all day and try to tackle as many issues as possible. We might need to push out a few updates to the widget itself, but luckily updating these connect widgets is so easy (only color settings need to be redone).

    Cheers!
    SH
     
  19. Steve Harris

    Steve Harris Museologist Staff Member Moderator

    215
    80
    Hmmm so strange considering our dev tested this yesterday and it seemed to work. Try embedding this in the head for a quick test:

    <link href="https://fonts.googleapis.com/css?family=Roboto+Condensed:300,300i,400,700" rel="stylesheet">
    <style>
    .ug-gallery-wrapper {
    font-family: 'Roboto Condensed', sans-serif !important;
    }
    </style>

    Does it show Roboto then?

    Thanks
    SH
     
  20. Steve Harris

    Steve Harris Museologist Staff Member Moderator

    215
    80
    Hey Wes - glad you liked the vid! Thanks for the feedback.

    One of our devs is currently looking into a link issue, but the way that Unite Gallery works for links is you first need to enable a "link icon" in the preset CSV. I believe only the tiled gallery options give you links (Mosaic and Uniform). That should give you a small chain icon on that can direct users to another link. You can also include whether you want the tile itself to just open a new link (without the icon option).

    I'm wondering if you could manually write links in the captions too. Just tried and you can! Sweet. So I just used this as a caption:

    This is an image <a href="http://www.google.com">sample</a>

    Result:

    upload_2016-10-20_7-44-34.png
     
    Adam Baker likes this.

Share This Page