Article Connect Formatting Problem

Discussion in 'Connect - CSV Widgets' started by IanM, Oct 13, 2017.

  1. IanM

    IanM Member

    19
    0
    Hi,

    This screen shot explains the problem I'm hoping to get some help with, https://cl.ly/n45m

    Also the video for this widget explains there is a URL slug, but this is not visible in the CSV I have for the Google CSV option.

    I get this slug from one of my articles. I've removed the full path but the extension is this, blog.html#!/merbau-decking which doesn't look to SEO friendly.
     
  2. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    2,862
    215
    Capture1.JPG Capture2.JPG
    Ian, let me address the first issues.
    Attached are two screen shots.
    Number 1 is where you can get rid of the Created text you were speaking of.
    The second is the CSV file where you can space out the Read more a bit. The only way I've found to do this, is to change line 34 to a higher number (which enlarges the box around the read more text).
    I then change the text box (lines 36, 37) to match the background color of the article (in this case I would change it to white, and change the text darker.
    I believe the numbering at the bottom of the page is generated by the number of articles and articles per page, but it must be in the code and not changeable in this version.
    I'll look at your other question, if no one else has answered yet.
    Hope this helps
    Dj
     
  3. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    2,862
    215
    Ian, addressing your question about the 'Slug' item in the video.
    If you are using the local spreadsheet approach (like Steve was doing in the video) a 'Slug' column is necessary.
    If you are using the google docs method, the docs create that for you (and I'm going to assume it's from the title).
    Hope this helps
    Dj
     
  4. IanM

    IanM Member

    19
    0
    Thanks DJ. I was able to wrap the more text in the spreadsheet in a paragraph tag which seems to have done the trick. It looks as though there is no bottom margin for the 'Read More' text in the CSS.

    Also the number 1 that is just sitting there with no context or label looks like it's for pagination. As there is only one page of articles it's showing 1. I'm using the CSV approach in google docs but not the google docs format; I'm using the HTML option. This CSV file looks like it's a bunch of variables that feed into a JavaScript file. Does that mean they have a variable to turn off pagination? Can you check with your team to see if I can add that variable to the CSV file, as the 1 is just silly hanging out there without any context. I need to be able to turn it off.
     
  5. IanM

    IanM Member

    19
    0
    DJ, does that mean that the slug option is not available for the HTML option in the Google CSV file? I'm not using the Google docs method.
     
  6. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    2,862
    215
    Ian, I believe that the "Slug" option you're referring to would be taken from the title in the Google Docs method, but if you are using the local CSV file method, it has the "Slug" column. Although, it is typically the same as the title only with the appropriate dashes instead of spaces.
    I'm going to recommend you place a support ticket (resources>contact us).
    I think the team can better answer your questions about how to remove the Pagination number.
    Thanks
    Dj
     
  7. cp84

    cp84 Member

    9
    0
    Has anyone figured out the "1" issue? I've encountering this as well.
     

Share This Page