Article Connect - Error in accessing google doc

Discussion in 'Connect - CSV Widgets' started by MaryChan, May 4, 2017.

  1. MaryChan

    MaryChan New Member

    3
    0
    Hi,

    I followed the instructions on the video tutorial but I kept seeing this error whenever it tries to access the google doc. (http://rosalindcarlson.com/test/blog.html)

    Fatal error: Can't use function return value in write context in /clientdata/n5200-2-static/r/o/rosalindcarlson.com/www/test/assets/mt-article-connect.php on line 9

    The page that I am testing Article Connect on is : http://rosalindcarlson.com/test/blo...-cultivate-customer-service-with-robust-ideas

    Hope someone can give me advice on how to solve this problem. I been looking for posts with similar problems but can't find any help on solving my problem.

    Thanks!
     
  2. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,349
    250
    Mary, may I ask, have you loaded the PHP file?
    Dj
     
  3. MaryChan

    MaryChan New Member

    3
    0
    Hi Dj,

    Yes., I have uploaded the mt-article-connect.php file to the assets folder. What else could I have missed out?
     
  4. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,349
    250
    Mary, I suggest placing a support ticket (resources>contact us).
    The team would be able to view your file and better examine the docs.
    Thanks
    Dj
     
  5. MaryChan

    MaryChan New Member

    3
    0
    Thank you, Dj. I will do that.

     
  6. Steven Farber

    Steven Farber Member

    15
    0
    Was this resolved? I have the same issue
     
  7. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,349
    250
    Steven, I have answered your other thread. It appears to be a PHP issue.
    Unfortunately the poster did not follow up with a ticket and or a response here.
    Dj
     
  8. Sidders

    Sidders Member

    21
    3
    Hi DJ

    Can you confirm this widget works with the latest release of Muse? I've had no issues with other connect widgets but cannot get this to work. I've uploaded the php file and linked the doc to the sheet and then the sheet to the widget. I just get the pre-loader and thats it as you can see here: https://www.europeanpostalsystems.co.uk/blog-test-local.html

    Any ideas? I use astutium for hosting and the server def supports php. Only thing I wondered is where exactly it needs to be? Muse uploads it to the assets folder and you didn't say this was wrong above?

    There is one thing when publishing the docs to the web is that the link it gives you to copy appears different to the one in the address bar, though this may well be standard for google?

    Cheers
    Tim
     
  9. DjHerold

    DjHerold Moderator Staff Member Advisory Group

    3,349
    250
    Sidders, the widget seems to be working good for me, and our demo works also.
    You may want to drop a line to support (resources>contact us) and see if they can look at your file.
    It may be something they can spot in the file that I can't see with just your URL.
    Thanks
    Dj
     

Share This Page